PowerSchool Release Notification

Security patches are super important.

You may want to patch this sooner rather than later.

PowerSchool Releases Available

A security vulnerability involving Apache Common Collections third party libraries was announced by CERT on Friday, November 13, 2015. The vulnerability could be used to remotely execute code on a server using the specific Apache libraries. PowerSchool 8.x and 9.x use these libraries.

Due to the severity of the vulnerability, PowerSchool recommends that you protect your PowerSchool server against these vulnerabilities as soon as possible by upgrading PowerSchool.

PowerSchool 9.1.1.1 is now available for download from PowerSource.

PowerSchool 8.3.0.3 is now available for download from PowerSource.

For detailed information about the release, see the PowerSchool Release Notes, available on PowerSource.